首页 > 新闻资讯 > WordPress官方发出通告:终结对PHP 4、 MySQL 4 的支持

WordPress官方发出通告:终结对PHP 4、 MySQL 4 的支持

24条评论
标签:
更多

今日,WordPress官方博客文撰文发出通告,他们将停止对PHP4、MySQL 4 的支持。WordPress一直以来对服务器的要求都是比较低的,这也是为了让用户有更加灵活的选择,因此,WordPress几乎在任何服务器上都能非常完美地运行。不过,服务器不断在发展,有必要对WordPress的服务器要求进行适当的调整,现在WordPress官方决定不再支持PHP 4、MySQL 4了。

首先一点,预计在几年年底推出的WordPress3.1将会是最后一个支持 PHP 4的版本。其次,预计2011年上半年推出的 WordPress 3.2,对PHP版本的最低版本要求将提高到PHP5.2版。为什么选择5.2呢?因为大多数WordPress用户都在使用这个版本,而且它比前几个版本有非常大的改善。DrupalJoomla等内容管理系统的下个版本(两者都将在今年推出)所支持的最低PHP版本也是5.2。目前只有大约11%的WordPress运行PHP5.2以下的版本,这其中大多数的主机都支持PHP 5.2 ,用户只需要在主机控制面板修改配置并激活PHP5.2即可。而且主机商也会意识到跟上步伐来支持最新的WordPress(或Drupal 、Joomla),今年过后这个比例肯定还会下降。

另外,WordPress官方还表示WordPress3.1之后也打算放弃支持MySQL 4。目前不到6%的WordPress用户在使用MySQL 4。WordPress3.2版本对MySQL的版本要求将变成5.0.15.

如果用户的主机环境没有达到要求,WordPress用户将无法升级到WordPress 3.2 。为了方便用户确认主机商所提供的版本支持,WordPress官方创建了 Health Check 插件。下载、安装、激活后,目前Health Check只会告诉你的主机是否适用于 WordPress 3.2。以后的版本将会向用户提供更加实用的服务器以及WordPress安装的信息。

总之,今年年底推出的WordPress 3.1将会是最后一个支持 PHP 4以及 MySQL 4的版本,2011年上半年推出的WordPress 3.2要求 PHP 5.2 或更高;MySQL 5.0.15 或更高。大家现在也可以安装Health Check插件来检查下自己的主机是否已经做好准备!

原文

* 版权声明:作者WordPress啦! 转载请注明出处。

#1
PHP4和MYSQL4都是过时的产品了
#2
第一次来。请多光照。
#3
强烈支持,这是一件好事啊。 嘿嘿,要是那天宣布终止对IE的支持就更好鸟啊!
#4
貌似现在使用的PHP版本都是5.0或以上的了。
#5
这是好事 还是坏事?
#6
这是一件好事情!
#7
看来又有动作了。
#8
评论输入验证码真烦
#9
现在应该早就升级了吧
#10
嗯,会时刻关注的
#11
还没有用过WP的系统,今年下半年准备用WP做个站玩玩,反正现在服务器空着也浪费。
#12
看来还不敢乱升级了。
#13
嘿嘿,豆丁来咯。。
#14
确实可以不支持了,
#15
看来我也应该用用WordPress 。
#16
强迫升级的感觉,嘿嘿
#17
因为MySQL4和PHP4都算是古董
#18
吓坏我了,我看看我的虚拟主机,是5.2。4,虚惊一场
#19
吓坏我了,我看看我的虚拟主机,是5.2。4,虚惊一场
#20
吓坏我了,我看看我的虚拟主机,是5.2。4,虚惊一场 http://aaccz.com/
#21
吓坏我了,我看看我的虚拟主机,是5.2。4,虚惊一场 http://aaccz.com/
#22
吓坏我了,我看看我的虚拟主机,是5.2。4,虚惊一场 http://aaccz.com/
#23
支持博主!
#24
嗯,博主还是不错哦的!