首页 > 新闻资讯 > WordPress插件兼容性检查器

WordPress插件兼容性检查器

0条评论
标签:
更多

前几天WordPress社区成员Andrea在Twitter上上传了这个查询表。

它的全名是WordPress插件兼容性查询表,它会对WordPress的版本库做规律性扫描,然后向插件作者显示对他们插件的描述是否符合实际。 根据至今为止收集到的数据,其中的确存在着一些误报的情况。 如果目前你使用的插件刚好也有这样的问题,建议你登录BraveNewCode论坛并描述自己遇到的问题,以便论坛上的人更正并提高资料的准确性。

从这个5月13日成立的数据库来看,4,920个插件中只有63.8%是与现实相符的。我觉得光是看看表单里各种各样的插件名称就是件很有意思的事了。 看完整个表格后,我发现最普遍的错误似乎都与 wp-content有关。 导致这些错误的最主要原因可能是:

Max WP——插件可兼容的WordPress最高版本。 对wp-content目录(2.6版本后可移动wp-content)进行硬编码,这是导致低版本的主要原因。 插件应引用WP_CONTENT_DIR,而不是直接引用wp-content。

不过这问题并不严重。我还发现一款很有意思的小插件——Podpress。 Podpress应该是查询表发现的错误之一。 你可以点开WordPress插件兼容性查询表看看Podpress的详细情况。

好好研究这份资料吧,把你发现的有趣的东西告诉我们。

原文:WordPress Plugin Compatibility Checker

* 版权声明:作者WordPress啦! 转载请注明出处。