首页 > 新闻资讯 > WordPress插件兼容性测试工具

WordPress插件兼容性测试工具

0条评论
标签:
更多

用户不愿意更新到WordPress最新版本的头号原因是害怕插件无法兼容。作为WordPress开发的一部分就是实现WordPress版本核心内容、插件和主题更新时能够尽量结合地完美,为此Michael Adams开发了插件目录中的一个新的“兼容性”功能,正在测试阶段,期待大家的参与。 在浏览插件目录中的插件时,选择一个WordPress版本和一个插件的版本,如果关于这个插件版本与WordPress版本有兼容性问题,我们将会显示出可兼容与不可兼容的百分比。

只要登陆到官方网站就可以帮助我们收集这类信息,只要选择一个WordPress以及插件版本组合在一起,然后点击“可兼容(Works)”或者 “不可兼容(Broken)” 按钮就可以了。不过注意,小问题就不要报告了。只有这个插件的核心功能真得无法在某个WordPress版本上实现,才可以按“不可兼容(Broken)” 按钮。

现在我们处于信息收集阶段,因此请大家都参与进来吧!也不要只顾投诉“不兼容”的插件,也请把你目前正在使用并且能与你的WordPress版本兼容的每一个插件告诉我们。这样可以有助于提高数据的准确度,避免因为一些人要求过于苛刻错将一些插件归入“不可兼容”的一类。

对于开发人员来说,我们开发时将把这些结果放入应用程序接口(API),plugin_information 命令返回 “compatibility” 多维数组格式的语句:

array( {WP version} => array( {plugin version} => array( {% of reporters who say it works}, {# responses} ) ) )

如果API 知道你正在使用的WordPress版本(例如,如果你使用 plugins_api() 函数查询),那么API就只会返回WordPress版本的兼容性信息。

最后,我们希望尽可能从WordPress内部获取插件的可兼容性信息,WordPress用户可以通过插件管理页面直接对这些插件投票,这么做的最终目的是在WordPress新版本更新时告诉大家插件的兼容性。为了使数据更加真实有效,我们需要大量的投票,现在开始吧。

原文:Plugin Compatibility Beta

* 版权声明:作者WordPress啦! 转载请注明出处。